Editing DXL

You can open a DXL file located in a project from the Project Explorer. You may alternatively open a DXL file outside of the workspace using the menu File > Open File.... However we recommend to organize your DXL files in the workspace to benefit from all features, like team collaboration, local history, and advanced code assist.

The DXL Editor enables you to:

All these options are configurable in Window > Preferences and General > Editors > Text Editors.

Syntax Highlight

Keywords, Strings, comment and built-in function calls are syntax highlighted in the editor.

Syntax Highlight

You may customize syntax colors used in Window > Preferences and DXL Editor > Syntax Coloring.

Mark Occurrences

The DXL Editor dynamically highlights all occurrences of the currently selected word. This enables you to quickly see the usage of a function or a variable in the edited file. This feature can be disabled using the Toggle Mark Occurrences action in the toolbar.

Mark Occurrences

Content Assist

Content assist provides you with a list of suggested completions for partially entered strings. In the DXL Editor press Ctrl+Space.

Code Assist suggests DXL keywords, constants and built-in functions. It also suggests functions declared in all DXL files that are part of the current project. This is why it is important that your project is correctly organized and that DXL files that are part of a project are consistent and meant to be used together.

Content Assist

Templates are shown together with the Content Assist proposals. There are existing templates, such as 'for', 'if' and more, but you can also define new templates. After applying a template, use the Tab key to navigate among the values to enter.

Code Templates

You may add new templates or customize predefined ones in Window > Preferences and DXL Editor > Templates. Templates definition can be exported and imported into another workspace, allowing team members to share common templates.

Text Hover

When the mouse is over a DXL function call, a tooltip shows up to display the function signature and its associated comment, if any.

Text Hover

Open Declaration

There are two ways that you can open a function declaration from a reference in the DXL Editor.

Related reference
Organizing DXL Projects
Using the DXL Help Manual